Resolved: Options - Series Opening Issue
Incident Report for MEMX
Postmortem

MEMX Options has identified the issue associated with the delayed opening of a subset of series that occurred on October 30, 2023, at 9:30 AM ET. The Exchange remediated the issue at 9:48 AM ET. All MEMX Options systems operated normally the remainder of the day October 30, 2023.

Posted Oct 30, 2023 - 16:23 EDT

Resolved
The options series opening issue on MEMX Options has been resolved. All MEMX Options systems are now operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Oct 30, 2023 - 09:51 EDT
Investigating
MEMX Options is investigating an issue with the opening of options series. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Oct 30, 2023 - 09:46 EDT
This incident affected: MEMX U.S. Options Exchange.