Routing Issue
Incident Report for MEMX
Resolved
This issue has been resolved. All MEMX systems are operating normally.
Posted Apr 01, 2021 - 07:26 EDT
Identified
MEMX has been made aware of a service provider issue impacting routing to away Exchanges. All MEMX systems are operating normally. Trading on MEMX is not impacted.
Posted Apr 01, 2021 - 07:12 EDT
Investigating
MEMX is currently investigating an issue impacting routing. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Apr 01, 2021 - 07:02 EDT
This incident affected: MEMX U.S. Equities Exchange.