TOP Under Review
Incident Report for MEMX
Resolved
Pursuant to Rule 11.15 MEMX, on its own motion, in conjunction with other exchanges and FINRA has determined to cancel all trades in security TOP that were executed on MEMX between 09:30:00 and 10:09:00 ET. This decision cannot be appealed. MEMX will be canceling trades on the participants behalf.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted May 12, 2023 - 11:11 EDT
Investigating
MEMX is investigating potentially erroneous transactions involving the security TOP executed between 09:30:00 - 10:09:00 ET today. Members should review their trading activity for potentially erroneous trades. The Exchange will advise with details as soon as available.
MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted May 12, 2023 - 10:49 EDT
This incident affected: MEMX U.S. Equities Exchange.