MEMX Options - Linkage Resolved

Incident Report for MEMX

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 09:51 EDT

Update

MEMX Options has resolved the issue impacting outbound linkage. All systems are operational.
Posted Jul 27, 2026 - 09:50 EDT

Update

We are continuing to investigate this issue.
Posted Jul 27, 2026 - 09:47 EDT

Investigating

MEMX Options is experiencing and issue was outbound linkage. Routable orders are being canceled back to customers. All other systems are operational.
Posted Jul 27, 2026 - 09:42 EDT
This incident affected: MEMX U.S. Options Exchange.