CTS Reporting Issue
Incident Report for MEMX
Resolved
MEMX has reported all trades impacted by the CTA disruption. All MEMX Systems are operating normally.
MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted May 05, 2021 - 11:51 EDT
Identified
MEMX experienced an issue with reporting quotes and trades to CTS SIP. Quote reporting has been restored. Trade reporting is currently being reestablished. All other MEMX systems are operating normally.
Posted May 05, 2021 - 11:43 EDT
This incident affected: MEMX U.S. Equities Exchange.