MEMX Equities Issue Resolved

Incident Report for MEMX

Postmortem

A redundant top of rack switch in the MEMX exchange’s network experienced an issue that caused corrupt ethernet packets to be forwarded to several applications making up the MEMX exchange. Upon identification, action was taken to shutdown the affected switch thereby allowing traffic to flow properly via the remaining switch in the redundant top of rack pair.

The MEMX exchange will replace the failed switch after market close.

Posted Dec 04, 2025 - 16:28 EST

Resolved

MEMX Equities has resumed trading in all symbols at 6:30 AM EST
Posted Dec 04, 2025 - 06:37 EST

Identified

MEMX Equities has identified the the issue and plans to resume trading all symbols at 6:30 AM EST.
Posted Dec 04, 2025 - 06:20 EST

Update

MEMX Equities has halted. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Dec 04, 2025 - 05:06 EST

Update

MEMX Equities is currently investigating an issue. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Dec 04, 2025 - 04:40 EST

Investigating

MEMX Equities is currently investigating an issue. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Dec 04, 2025 - 04:37 EST
This incident affected: MEMX U.S. Equities Exchange.