MEMX Equities has declared self-help against Nasdaq
Incident Report for MEMX
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 20:35 EST
Monitoring
MEMX Equities has declared self-help against Nasdaq per rule 611 of Regulation NMS. Routing to this destination has been suspended as of 2:57 PM ET.

All MEMX Equities systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Dec 13, 2023 - 14:57 EST
This incident affected: MEMX U.S. Equities Exchange.