Clearly Erroneous Ruling - REDU
Incident Report for MEMX
Resolved
Pursuant to Rule 11.15 MEMX, on its own motion and in conjunction with other exchanges and FINRA has determined to cancel all trades in security REDU - RISE Education Cayman Ltd at and above $1.72 that were executed on MEMX between 00:07:00 ET and 08:06:00 ET. This decision cannot be appealed. MEMX will be canceling trades on the participants behalf.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Jun 10, 2022 - 09:49 EDT
Investigating
MEMX is investigating potentially erroneous transactions involving the security REDU - RISE Education Cayman Ltd executed between 07:00:00 ET and 08:06:00 ET today. Members should review their trading activity for potentially erroneous trades. The Exchange will advise with details as soon as available.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Jun 10, 2022 - 09:30 EDT
This incident affected: MEMX U.S. Equities Exchange.