MEMX Equities has revoked self-help against Nasdaq
Incident Report for MEMX
Resolved
MEMX Equities has revoked self-help against Nasdaq. Routing to this destination has resumed as of 07:48 AM ET

All MEMX systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Mar 18, 2024 - 07:49 EDT
Monitoring
MEMX Equities has declared self-help against Nasdaq. Routing to this destination has been suspended as of 07:00:00 ET.

All MEMX Equities systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Mar 18, 2024 - 07:01 EDT
This incident affected: MEMX U.S. Equities Exchange.