Options - Routing Disabled

Incident Report for MEMX

Resolved

MEMX Options will resume routing on Monday, April 20, 2026. All MEMX systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Apr 17, 2026 - 16:20 EDT

Monitoring

MEMX Options is experiencing and issue with a third-party routing provider and has disabled routing. All orders eligible to route will be canceled back to clients. All MEMX Systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Apr 17, 2026 - 15:08 EDT
This incident affected: MEMX U.S. Options Exchange.