MEMX Options Linkage availability

Incident Report for MEMX

Resolved

MEMX Options is back to routing. All MEMX Options systems are operating normally.
Posted Aug 12, 2026 - 11:30 EDT

Investigating

MEMX Options is currently experiencing an issue with a third party linkage provider. Routable orders are being canceled back to customers. All MEMX Options systems are operating normally.
Posted Aug 12, 2026 - 09:59 EDT
This incident affected: MEMX U.S. Options Exchange.