Delayed Clearing Submissions
Incident Report for MEMX
Resolved
MEMX has resumed submission of clearing records as of 10:09 AM ET. All MEMX systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Jan 13, 2022 - 10:17 EST
Identified
MEMX is experiencing delayed clearing submissions as of 9:06 AM ET. Additional notice will be provided when clearing submissions resume. All other MEMX systems are operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Jan 13, 2022 - 09:29 EST
This incident affected: MEMX U.S. Equities Exchange.