Resolved: Options - Systems Issue
Incident Report for MEMX
Resolved
MEMX Options has resolved the systems issue. Connectivity to MEMX Options is now available. All systems are now operating normally.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Nov 15, 2023 - 08:59 EST
Identified
MEMX Options is experiencing a systems issue. Trading has not commenced for November 15, 2023. More information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Nov 15, 2023 - 08:13 EST
This incident affected: MEMX U.S. Options Exchange.