Delayed Start of Pre-Market Session - Resolved
Incident Report for MEMX
Resolved
The networking issue has been identified and resolved. The pre-market session will begin at 07:15:00 AM ET.
Posted May 08, 2023 - 07:15 EDT
Investigating
MEMX is currently investigating a networking issue and will delay the start of the pre-market session. Additional information to follow.
Posted May 08, 2023 - 06:55 EDT
This incident affected: MEMX U.S. Equities Exchange.