Options - Market Data Issue - Resolved
Incident Report for MEMX
Postmortem

On February 12, 2024, MEMX Options (the “Exchange”) experienced a message sequence gap on a subset of OPRA lines, which were incorrectly processed because of the mishandling of the OPRA sequence rollover from OPRA weekend testing. This, in turn, led to locked and/or crossed market data on a range of options series (i.e. “Option IDs”). 

The root cause was determined to be an issue processing message sequence gaps after an OPRA sequence rollover. During OPRA weekend testing, SIAC tested the rollover of sequence numbers, which exposed a latent bug in the Exchange's OPRA channel gap recovery logic.  

The Exchange failed over to a backup instance of the software responsible for processing the affected OPRA lines, which corrected the market data in the affected Option IDs by triggering a recovery process. A latent software error in this recovery process caused 210 Option IDs to remain in a locked/crossed condition requiring MEMX Options to halt trading in these Option IDs for the remainder of the trading day. 

MEMX Market Operations | mops@memx.com | 1-833-415-6677

Posted Feb 12, 2024 - 17:09 EST

Resolved
MEMX failed over to back-up market data processes at 10:38 AM ET to resolve the issue. A postmortem summary will be provided after market close today, February 12, 2024.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Feb 12, 2024 - 10:52 EST
Investigating
MEMX Options is investigating an issue impacting market data distribution. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Feb 12, 2024 - 09:55 EST
This incident affected: MEMX U.S. Options Exchange.