Clearly Erroneous Ruling - ONON
Incident Report for MEMX
Resolved
Pursuant to Rule 11.15 MEMX, on its own motion, in conjunction with other exchanges has determined to cancel all trades in security On Holding AG (ONON) at and below $14.33 that were executed on MEMX between 16:00:02 and 16:01:00 ET. This decision cannot be appealed. MEMX will be canceling trades on the participants behalf.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Sep 28, 2022 - 17:26 EDT
Monitoring
MEMX is investigating potentially erroneous transactions involving the security On Holding AG (ONON) executed between 16:00:02 and 16:01:00 ET today. Members should review their trading activity for potentially erroneous trades and request review through the Clearly Erroneous process within the applicable timeframe for filing pursuant to MEMX Rule 11.15. The Exchange will advise with details as soon as available.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Sep 28, 2022 - 17:04 EDT
This incident affected: MEMX U.S. Equities Exchange.