Delayed State of Pre-Market Session
Incident Report for MEMX
Resolved
The inbound market data issue has been identified and resolved. The pre-market session will begin at 07:15:00 AM ET
Posted Jun 05, 2023 - 07:07 EDT
Investigating
MEMX is currently investigating an issue with inbound market data and will delay the opening of the pre-market. Additional information to follow.

MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Jun 05, 2023 - 06:58 EDT
This incident affected: MEMX U.S. Equities Exchange.