MEMX Equities Routing Issue
Incident Report for MEMX
Resolved
MEMX Equities has stopped routing for the remainder of the trading day. All MEMX systems are operating normally. Trading on MEMX is not impacted.
Posted Dec 21, 2023 - 15:53 EST
Investigating
MEMX Equities is currently experiencing a service provider issue impacting routing to away Exchanges. All MEMX systems are operating normally. Trading on MEMX is not impacted. Additional information to follow.
MEMX Market Operations | mops@memx.com | 1-833-415-6677
Posted Dec 21, 2023 - 15:47 EST
This incident affected: MEMX U.S. Equities Exchange.