Market Data Ingestion Issue
Incident Report for MEMX
Resolved
The issue with market data ingestion in symbols A-L has been resolved.
Posted Mar 29, 2021 - 11:23 EDT
Investigating
The Exchange is currently investigating an issue with market data ingestion in symbols A-L.
Posted Mar 29, 2021 - 11:13 EDT
This incident affected: MEMX U.S. Equities Exchange.